Common Problems

Compatibility problems / Bridgeboard Problems

The best way to think of the Bridgeboard is as an IBM on a card stuck in your Amiga. The only parts of the IBM that are being emulated are the keyboard, mouse, hard drive, and display. Even for some of these they can be replaced by the real thing. For example its possible to install a Microsoft mouse, or a I/O card with a real hard drive or a VGA card. Despite all of that, you might still find some software or hardware that doesn't like the Bridgeboard. Below are some problems and their fixes (if they have one):

DosShell turns to garbage when I select a graphics display

This is a fault of the AMouse driver. You must either run DosShell in a text display or use a real Microsoft compatible mouse.

The AMouse driver doesn't operate with program "#####"

Check if the program looks for a specific text string in the driver code, and if it does, use the AMouse \c option. Otherwise, your only fix for this is to install a real Microsoft compatible mouse on the Bridgeboard.

My hardfiles don't work

The most common problem is that you have an 68030/040 CPU. With these CPUs you need to either:

  • Turn the CPU DataCache off or
  • Install the Enforcer utility (if your CPU has an MMU)

My hardfile access is very slow.

If you increase the buffers on the hard drive that has the hard file on it your access time will improve. You need to add A LOT of buffers to make it faster (like 800 to 1000 buffers). Also, hardfile speed is based on the size of the hardfile, a large hardfile is slower than a smaller one. (Check out JanusTools for partition support).

I can't get the AMouse or ATime to work on the Bridgeboard side unless I do a warm boot on the PC side.

(This might happen after doing an install of some software or hardware drivers)

From: Stewart Hunt

Try the following:

Open your config.sys file and look for a "Stacks=9,256" line.
If it is present or missing, either change it to read, or add the line,


Save the new Config.sys file and reboot, the problem should go away.
Some MS-DOS versions try to "help" device drivers by providing them witha new interrupt stack. IRQ3 (used by Janus for hardware AND SOFTWARE interrupts) is frequently a victim of Microsoft's benevolent aid, and their stack switching code destroys registers which are parameters for software IRQ3 calls to Janus, and thus Janus cannot be reached by applications. Stacks=0,0 says "Don't help me Microsoft".

My A2286 (or other) Bridgeboard locks up intermittently.

From: Scott Drysdale

(Peter Kittel) writes:

If you have such mysterious faults with your bridgeboard, I assume the old story: contacts, contacts, contacts. Reseat all socketed chips. Reseat all cables. Reseat card in its slot. If it doesn't help, try again. One BB of mine needed 5 attempts until it worked.
Keep trying.

also get janus 2.1 if you haven't already. there are gazillions of small bugs in janus 2.0 that can team up to form one big bug when the temperature, humidity, and phase of the moon are all just right. in your reseating activities, pay particular attention to the alignment of the card fingers with the corresponding metal brushes in the motherboard connectors. some bridgeboards and/or amigas have slight misalignments, and you may want to file a little bit off the edges of the bridgeboard connectors... Zorro_Connector

file at the two 'a' areas to get the fingers more to the left. file at the two 'b' areas to get the fingers more to the right. the AT bus connector's brushes may align differently with the board's fingers than the zorro stuff. find a happy medium that keeps both as close to centered as possible.

My floppy drive doesn't work.

From: Scott Drysdale

since i've been asked about shared drive woes by several people, i'll describe your problem and another common (and much worse) problem.

your problem is most likely noise. early dual-speed drives were very very sensitive to environmental noise. how to "fix" this one is too dependent on the individual machine. the drive could also need cleaning. it might be dead. try to borrow another 357A drive and see if it works with your 2386 (test all four combinations - amiga DD & HD and PC DD & HD).

here's how the shared drive thing works: BB_FloppyCable

the A/B switch (flipper hardware) is really more than a simple switch. it has to allow the amiga to detect disk insertion/removal even while the PC owns the drive, and it also controls the dual-speed drive's "gearshift." the switch is built out of several PALs and is controlled by a few jumpers and the software-controlled configuration registers.

what happens is the PALs go bad. i've heard of GAL chips "reprogramming" themselves due to overshoot on their i/o lines, which gets rectified and fed to the chip's power supply. i suspect this is what's happening, given the miles & miles of ribbon cable the signals are travelling through. my bridgeboard at home has this problem - maybe one in 50 power ups result in a working shared floppy drive. in my case, the bridgeboard speaker also stops working (which tends to implicate a particular PAL, but i don't remember which one).

your options:

  1. hook up an A1010/A1011 drive to the rear port of the 2386. this gives you a 720K external PC drive.
  2. do #1, but install a real IBM PC compatible high-density drive in the A1010/A1011 enclosure. the A1011 is probably easier, since it uses a more modern mechanism. you'll probably have to play with the select jumpers on the drive you use.
  3. install a real IBM PC compatible high-density drive using one of your drive bays. attach the drive to the "internal" cable that came with the bridgeboard.
  4. find a service place (try ESCOM, CEI, or SMG) that can make you a new set of PALs. i don't know which one(s) die, so get a whole set. i'd get out a scope and watch the signals to see if they're over/undershooting badly, and try to fix it with diodes/pullups/series resistors.
  5. if you have no need to boot the PC side from floppies, run CrossDOS on a dual-speed drive. use AREAD/AWRITE to move files back & forth.

if you change anything, don't forget to tell both PC BIOS and PCPrefs about the changes.

An other possible solution is to reduce the size of the ribbon cables as described in 'Installation tips' in Bridgeboard Tips and Utilities

I have problems getting my Bridgeboard to work when I have 8MB of RAM on my Amiga

as best described by: Michael Pederson

The problem with BridgeBoard Autoconfig occurs only in Zorro II based Amigas and is common to all BridgeBoards. The Zorro III Amigas configure RAM outside the Zorro II address space and so they don't run into a conflict. It's caused by the BridgeBoard trying to Autoconfig itself into Zorro II FastRAM address space, of which there are only 8 Mbytes available. If this is already occupied by 8 Mbytes of FastRAM, a BridgeBoard will lose.
The only solution to this problem is to limit the amount of FastRAM to 7.5 Mbytes; as you've pointed out, most upgrades are in increments of 2 Mbytes so in practice the limit becomes 6 Mbytes of FastRAM. The only cards I know off the top of my head that aren't restricted to 2 Mbytes are the A2090/2091 SCSI controllers. These can be configured to 1/2, 1 or 2 Mbytes FastRAM.

Please also note that the DKB2630 board can apparently add memory outside the Zorro II Autoconfig space, thus solving the problem.

Always getting a message that Janus.library cannot be found.

This could be caused by a couple of different things.

  • You don't have the "binddrivers" statement in your startup-sequence.
  • You don't have the "Janus.library" in the Expansion drawer on your boot drive.
  • You have all 8 megabytes of Autoconfig RAM used up (can only have 6 megabytes of Autoconfig RAM for Zorro II Amigas; see above)

I can't get my floppy to be shared with the Bridgeboard in an A4000T

It's not possible to share the floppy with the Bridgeboard in an A4000T setup because of some differences in the onboard floppy controller of the system. Your only option is to use a dedicated floppy drive for the Bridgeboard.

After upgrading the A2386SX's CPU, my FPU unit no longer works/gives errors or programs refuse to work properly.

It has been reported that some CPU upgrades/FPUs are incompatible with each other. The Cyrix Cx486Srx2 upgrade is known to be incompatible to most (if not all) FPU coprocessors. The Bridgeboard CPU Upgrade Guide has additional information on these problems. From: Stewart Hunt

The Cyrix Cx486Srx2 microprocessor upgrade chip has been widely used to upgrade the C=2386 bridgeboard to levels similar to a 33 MHz 486 system. I have the 50 MHz chip installed over the 25 MHz Intel 386 SX processor. If a 387SX math coprocessor chip is installed on the bridgeboard, diagnostic software indicates a 486DX processor is in place. While the Cyrix microprocessor claims to be compatible with most any math coprocessor installed in the math coprocessor socket, my own personal experience to this point, indicates that it is NOT. I have tried the Cyrix Fastmath 387 chip, the Intel 387 chip, and the ULSI 387 chip. Both the Cyrix and Intel chips fail the Transcendental math tests, included in the Cyrix or Intel advanced diagnostic software which is provided by the respective manufacturers. The Intel 387 chip also fails the Environment test which tests the 80 bit wide internal math co-register stack. The Transcendental test is for trigonometric, exponential and logarithmic functions. When the Cyrix CPU chip is removed from the 2386 BB the diagnostic tests are all passed successfully and the diagnostic software indicates that the math coprocessor is installed and operating correctly. Disabling the cache on the Cyrix CPU still results in the failure of the diagnostic tests on the Transcendental and Environment tests. All of the other math coprocessor tests are successful. Clearly, the tests seem to point to an incompatibility of the Cyrix chip, and the 8387 math coprocessor on Bridgeboard systems. Ignoring the diagnostic errors, has been of little consequence running DOS and Windows software, but it will cause major grief running OS/2 applications.

Something to keep in mind, however:

From: Scott Marlowe

Please note that MANY of the "transcendental tests" written by one manufacturer will FAIL on anyone else's math chip due to the last bit being wrong according to these tests. The problem here is that the last bit is often not considered reliable, but they test it anyway. I remember reading about how INTEL wrote a tran test for their 387 mathco that then failed on the 486DX, because the 486DX was more accurate. Don't get worried about the last bit or manufacturer's tests.

One possible cure is to remove jumper J101 on the Bridgeboard, which disables Pipeline mode. This may get programs that usually don't work with the FPU to work properly, at the cost of a slight performance loss.

I get a BIOS checksum error when I boot the Bridgeboard

This might happen if you have a DMA SCSI controller (or possibly other DMA device) on your Amiga. This problem often shows up on A4000Ts (because of its SCSI controller). The JanusTools package (see Bridgeboard Tips and Utilities) has a small program called 'januspatch' that solves this problem.

Text based on BBFAQ © Sébastien Boisvert
Last Update: 19.07.2023